Related queue bottlenecks appear to be resolved at this point.
Resolved
Monitoring
We've deployed a fix and are monitoring to ensure that the issue is resolved.
Investigating
We're investigating an apparent increase in queue time.
·