Queue Back Up
Resolved·Degraded performance

We identified some issues with our fair scheduler and patched them. Longer term mitigations are on their way!

Mon, Jun 30, 2025, 04:17 PM
(1 month ago)
·
Affected components
Updates

Resolved

We identified some issues with our fair scheduler and patched them. Longer term mitigations are on their way!

Mon, Jun 30, 2025, 04:17 PM

Monitoring

We're continuing to monitor our changes, most requests appear to be succeeding due to our fair queueing system.

Mon, Jun 30, 2025, 03:45 PM(31 minutes earlier)

Identified

Seeing increased queue times for non-priority/async requests on the API queue. We've identified an immediate fix, and are monitoring queue length as it trends down.

Mon, Jun 30, 2025, 03:24 PM(21 minutes earlier)