Elevated 503 and Pending Jobs
Resolved·Degraded performance

Fully resolved. No more latency impact in production. Post-mortem to come.

Thu, Aug 14, 2025, 09:07 PM
(1 week ago)
·
Affected components
Updates

Resolved

Fully resolved. No more latency impact in production. Post-mortem to come.

Thu, Aug 14, 2025, 09:07 PM

Monitoring

We moved off of the previous cloud provider as we were seeing high queue times there. It appears that latency is now within a normal range, though on the new cloud provider ~50% higher than our normal levels, we are continuing to investigate root cause and a way to get back to normal latency without downtime.

Thu, Aug 14, 2025, 05:06 PM(4 hours earlier)

Monitoring

Continuing to monitor and seeing increased latency but jobs completing at a regular cadence. Continuing to investigate latency impact.

Thu, Aug 14, 2025, 04:42 PM(23 minutes earlier)

Monitoring

We are seeing 503s reduced at the moment after applying a mitigation and are monitoring for any additional issues.

Thu, Aug 14, 2025, 04:17 PM(25 minutes earlier)

Investigating

We are investigating elevated 503 and pending events on the API.

Thu, Aug 14, 2025, 04:11 PM