Resolved
The issue is mitigated, but we are continuing to monitor.
Identified
We identified an issue with an update that led to jobs not correctly queueing after they were sent to our system for processing. We are rolling back the change immediately.