Resolved
This is resolved. The cause was a Redis connection issue, which we have fixed. Extract and Split latency is back to normal. Thank you for your patience.
Investigating
We are seeing elevated latency on Extract and Split requests. Requests are completing, but slower than normal. We are investigating and will post an update shortly.