Resolved
This is resolved. The GPU cluster issue has been fixed and parse latency has returned to normal. We confirmed recovery across the fleet. Thank you for your patience.
Identified
Elevated latency for parse, due to an issue with one of our gpu clusters. We've identified the problem and are actively fixing it.